Oops! It appears that you have disabled your Javascript. In order for you to see this page as it is meant to appear, we ask that you please re-enable your Javascript!
+55 (11) 4506-3239
academy@glsolutions.com.br

18 fev 2013

Ratinal Application Developer falha durante inicialização

/
Postado por
/
Comments0

Durante a inicialização do IBM Rational, o mesmo para abruptamente interrompendo o processo de inicialização. Ao analisar o arquivo de javacore.txt localizado no home da aplicação, encontramos a seguinte mensagem.

0SECTION       TITLE subcomponent dump routine
NULL           ===============================
1TICHARSET     UTF-8
1TISIGINFO     Dump Event “gpf” (00002000) received 
1TIDATETIME    Date:                 2013/02/11 at 9:32:38
1TIFILENAME    Javacore filename:    /opt/IBM/RAD/javacore.000.0000.000.txt
1TIREQFLAGS    Request Flags: 0x81 (exclusive+preempt)
1TIPREPSTATE   Prep State: 0x100 (trace_disabled)
1TIPREPINFO    Exclusive VM access not taken: data may not be consistent across javacore sections
NULL           ————————————————————————
0SECTION       GPINFO subcomponent dump routine
NULL           ================================
2XHOSLEVEL     OS Level         : Linux 2.6.18-308.4.1.el5
2XHCPUS        Processors –
3XHCPUARCH       Architecture   : x86
3XHNUMCPUS       How Many       : 2
3XHNUMASUP       NUMA is either not supported or has been disabled by user
NULL           
1XHEXCPCODE    J9Generic_Signal_Number: 00000004
1XHEXCPCODE    Signal_Number: 0000000B
1XHEXCPCODE    Error_Value: 00000000
1XHEXCPCODE    Signal_Code: 00000001
1XHEXCPCODE    Handler1: 00125A1A
1XHEXCPCODE    Handler2: 001CCA67
1XHEXCPCODE    InaccessibleAddress: 00D5F000
NULL           
1XHEXCPMODULE  Module: /usr/lib/xulrunner-2/libxul.so


Atenção a mensagem “1XHEXCPMODULE  Module: /usr/lib/xulrunner-2/libxul.so ”

A causa do problema está relacionado a incompatibilidade com o Eclipse de versão  xulrunner.

Navegando até o diretório de instalação do  xulrunner /usr/lib/xulrunner-2/libxul.so, execute o comando ./xulrunner -v.
A versão no caso deste exemplo, é 10.0.12 sendo incompatível com o Eclipse. Dessa forma, no momento da inicialização do Rational ao tentar carregar o xulrunner, o mesmo é interrompido.

Este problema ocorre apenas em sistemas operacionais Linux.

Solução

O Eclipse é compatível apenas com a versão 1.8.1.3 – 3.6.x do  xulrunner.

1. Faça o download da versão compatível do xulrunner:
64-bit xulrunner download
32-bit xulrunner download

2. Descompacte o arquivo xulrunner-1.9.2.13.en-US.linux-x86_64.tar.bz2 em qualquer diretório.

3. Edite o arquivo eclipse.ini. Logo abaixo de -vmargs, adicione a propriedade:

-Dorg.eclipse.swt.browser.XULRunnerPath=/opt/xulrunner/1.8.1.3/xulrunner (Diretório onde o arquivo xulrunner, foi descompactado).

4. Em alguns produtos IBM Worklight Studio installations, é necessário inserir a propriedade no arquivo Worklight.sh  ao invés do arquivo eclipse.ini.

5. Reinicie o Ratinal Application Developer

Deixe um comentário