+55 (11) 4506-3239
academy@glsolutions.com.br

23 mar 2010

Portal falha ao iniciar quando compartilha o banco Customization para migração

//
Comments0

Uma das etapas da migração entre o WebSphere Portal 6.0.1.x e 6.1 é o compartilhamento do banco customization da versão 6.0.1.x com a versão 6.1.
A recomendação do documento WCMv60to61MigrationGuide.pdf é que deve ser instalado no WebSphere Portal 6.0.1.x o ifix PK69096 que é para a versão 6.0.1.1. Porém, nesta migração a versão do WebSphere Portal é 6.0.1.6 que seguindo o conceito de fixpack da IBM onde os ifix de versão anteriores já estão no pacote atual. Neste caso a versão 6.0.1.6 já vem com esse ifix PK69096. No processo de compartilhamento do banco customization (Share customization) o portal 6.1 falha ao iniciar. O problema ocorre pois é necessário rodar os comandos abaixo antes de iniciar o portal 6.1.

  • {WAS_PROFILE_ROOT}/ConfigEngine/ConfigEngine.sh|bat remove-wcm-migration -DPortalAdminPwd= -DWasPassword=
  • {WAS_PROFILE_ROOT}/ConfigEngine/ConfigEngine.sh|bat configure-wcm-migration -DPortalAdminPwd= -DWasPassword=
  • {WAS_PROFILE_ROOT}/ConfigEngine/ConfigEngine.sh|bat update-wcm -DPortalAdminPwd= -DWasPassword=

Esse comando não deveria ser executado na versão 6.0.1.6 pois ao aplicar o fixpack 6.0.1.6 ele já deveria executar esse procedimento. Porém, acredito que ele não execute as tarefas acima e neste caso para não ter problemas na inicialização do portal 6.1 rode os comandos acima e depois inicie o portal 6.1.

Leave a Reply